Customer Self Serve

            Not all browsers are compatible with Customer Self Serve. For Internet Explorer you will need IE9 or above

            Or why not use an alternative browser such as Chrome or Firefox